Skip to main content
← All vulnerabilities
CVE-2015-10009GHSA-CP2P-6XH4-JMCP

nterchange code_caller_controller.php getContent code injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a nterchange

    4.0, 4.1

  • nonfiction/nterchangePackagist

    fixed in 4.1.1

References 4

vuldb.com

GitHub · nonfiction/nterchange_backend