CVE-2015-0227GHSA-6R5V-HP32-FJQW
Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.6.17, 2.02
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- org.apache.ws.security:wss4jMaven
fixed in 1.6.17
- org.apache.ws.security:wss4jMaven
From 2.0.0 · fixed in 2.02
- wss4j:wss4jMaven
fixed in 1.6.17