Skip to main content
← All vulnerabilities
CVE-2015-0226GHSA-VJWC-5HFH-2VV5

Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.6.17, 2.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.ws.security:wss4jMaven

    fixed in 1.6.17

  • org.apache.wss4j:wss4j-ws-security-domMaven

    From 2.0.0 · fixed in 2.0.2

References 11

access.redhat.com

rhn.redhat.com

support.hpe.com

ws.apache.org

securityfocus.com

oracle.com