Skip to main content
← All vulnerabilities
CVE-2015-0218GHSA-5JPH-MVFM-R27P

Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.7, 2.7.4, 2.8.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.7

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.4

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.2

References 3

moodle.org

git.moodle.org

openwall.com