Skip to main content
← All vulnerabilities
CVE-2015-0217GHSA-P497-37FC-XVVC

filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenti

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.7, 2.7.4, 2.8.2
None on Exploit-DB, Metasploit or GitHub

Summary

filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.7

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.4

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.2

References 3

git.moodle.org

moodle.org

openwall.com