Skip to main content
← All vulnerabilities
CVE-2015-0211GHSA-FRHC-9HWC-X7J3

mod/lti/ajax.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 does not consider the moodle/course

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.7, 2.7.4, 2.8.2
None on Exploit-DB, Metasploit or GitHub

Summary

mod/lti/ajax.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 does not consider the moodle/course:manageactivities and mod/lti:addinstance capabilities before proceeding with registered-tool list searches, which allows remote authenticated users to obtain sensitive information via requests to the LTI Ajax service.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.6.7

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.4

  • moodle/moodlePackagist

    From 2.8.0 · fixed in 2.8.2

References 3

git.moodle.org

moodle.org

openwall.com