Skip to main content
← All vulnerabilities
CVE-2014-9390PYSEC-2020-217GHSA-6VVC-C2M3-CJF3

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.3, 3.5.3
1 Metasploit module

Summary

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • mercurialPyPI

    fixed in 3.2.3

  • org.eclipse.jgit:org.eclipse.jgitMaven

    fixed in 3.5.3

References 10

news.ycombinator.com

article.gmane.org

git-blame.blogspot.com

mercurial.selenic.com

support.apple.com

GitHub · blog/1938-git-client-vulnerability-announced

securitytracker.com

GitHub · libgit2/libgit2

libgit2.org

GitHub · rapid7/metasploit-framework