Skip to main content
← All vulnerabilities
CVE-2014-9059GHSA-CRCQ-PW8H-9XWF

lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.9, 2.6.6, 2.7.3
None on Exploit-DB, Metasploit or GitHub

Summary

lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information in HTTP headers, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via UTF-7 characters during interaction with AJAX scripts.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.5.9

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.6

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.3

References 5

securitytracker.com

openwall.com

git.moodle.org

moodle.org

securityfocus.com