Skip to main content
← All vulnerabilities
CVE-2014-8089GHSA-QH9W-R7G5-Q939

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.12.9, 2.0.99, 2.1.99, 2.2.8, 2.3.3
None on Exploit-DB, Metasploit or GitHub

Summary

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • zendframework/zendframework1Packagist

    From 1.12.0 · fixed in 1.12.9

  • zendframework/zend-dbPackagist

    From 2.0.0 · fixed in 2.0.99

  • zendframework/zend-dbPackagist

    From 2.1.0 · fixed in 2.1.99

  • zendframework/zend-dbPackagist

    From 2.2.0 · fixed in 2.2.8

  • zendframework/zend-dbPackagist

    From 2.3.0 · fixed in 2.3.3

  • zendframework/zendframeworkPackagist

    From 2.0.0 · fixed in 2.0.99

  • zendframework/zendframeworkPackagist

    From 2.1.0 · fixed in 2.1.99

  • zendframework/zendframeworkPackagist

    From 2.2.0 · fixed in 2.2.8

  • zendframework/zendframeworkPackagist

    From 2.3.0 · fixed in 2.3.3

References 4

securityfocus.com

seclists.org

bugzilla.redhat.com

framework.zend.com