CVE-2014-8088GHSA-F6RC-RH43-H8GR
The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote atta
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.99, 2.1.99, 2.2.8, 2.3.3, 1.12.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- zendframework/zendframeworkPackagist
From 2.0.0 · fixed in 2.0.99
- zendframework/zendframeworkPackagist
From 2.1.0 · fixed in 2.1.99
- zendframework/zendframeworkPackagist
From 2.2.0 · fixed in 2.2.8
- zendframework/zendframeworkPackagist
From 2.3.0 · fixed in 2.3.3
- zendframework/zendframework1Packagist
From 1.12.0 · fixed in 1.12.9