Skip to main content
← All vulnerabilities
CVE-2014-7847GHSA-6VJG-2Q57-RGFW

iplookup/index.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote attackers to cause

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.9, 2.6.6, 2.7.3
None on Exploit-DB, Metasploit or GitHub

Summary

iplookup/index.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote attackers to cause a denial of service (resource consumption) by triggering the calculation of an estimated latitude and longitude for an IP address.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.5.9

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.6

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.3

References 4

moodle.org

securitytracker.com

openwall.com

git.moodle.org