Skip to main content
← All vulnerabilities
CVE-2014-7846GHSA-468Q-9CMP-76WC

tag/tag_autocomplete.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not consider the mood

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.9, 2.6.6, 2.7.3
None on Exploit-DB, Metasploit or GitHub

Summary

tag/tag_autocomplete.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not consider the moodle/tag:edit capability before adding a tag, which allows remote authenticated users to bypass intended access restrictions via an AJAX request.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.5.9

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.6

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.3

References 4

securitytracker.com

openwall.com

git.moodle.org

moodle.org