Skip to main content
← All vulnerabilities
CVE-2014-7845GHSA-9V64-447R-WCH6

The generate_password function in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide a s

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.3, 2.6.6, 2.5.9
None on Exploit-DB, Metasploit or GitHub

Summary

The generate_password function in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide a sufficient number of possible temporary passwords, which allows remote attackers to obtain access via a brute-force attack.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.3

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.6

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.9

References 4

git.moodle.org

securitytracker.com

moodle.org

openwall.com