Skip to main content
← All vulnerabilities
CVE-2014-7830GHSA-J4MR-VC54-H5PC

Cross-site scripting (XSS) vulnerability in mod/feedback/mapcourse.php in the Feedback module in Moodle through 2.4.11, 2.5.x before 2.5.9,

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.9, 2.6.6, 2.7.3
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in mod/feedback/mapcourse.php in the Feedback module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the mod/feedback:mapcourse capability to provide a searchcourse parameter.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.5.9

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.6

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.3

References 5

git.moodle.org

securitytracker.com

securityfocus.com

openwall.com

moodle.org