CVE-2014-7144GHSA-7F2C-VP52-GMFWPYSEC-2014-26PYSEC-2014-71
OpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification whe
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.11.0, 1.2.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
OpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- keystonemiddlewarePyPI
fixed in 0.11.0
- keystonemiddlewarePyPI
From 1.0 · fixed in 1.2.0
- python-keystoneclientPyPI
fixed in 0.11.0
- python-keystoneclientPyPI
From 1.0 · fixed in 1.2.0
- keystonemiddlewarePyPI
fixed in 0.11.0; From 1.0 · fixed in 1.2.0
- python-keystoneclientPyPI
fixed in 0.11.0; From 1.0 · fixed in 1.2.0