Skip to main content
← All vulnerabilities
CVE-2014-6393GHSA-GPVR-G6GH-9MC2

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 le

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.11.0, 4.5.0
None on Exploit-DB, Metasploit or GitHub

Summary

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • expressnpm

    fixed in 3.11.0

  • expressnpm

    From 4.0.0 · fixed in 4.5.0

References 2

nodesecurity.io

bugzilla.redhat.com