Skip to main content
← All vulnerabilities
CVE-2014-4616GHSA-9772-CWX9-R4CJPSF-2017-1PYSEC-2026-921

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-depend

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.1
None on Exploit-DB, Metasploit or GitHub

Summary

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • simplejsonPyPI

    fixed in 2.6.1

References 9

hackerone.com

bugs.debian.org

rhn.redhat.com

securityfocus.com

lists.opensuse.org

security.gentoo.org

openwall.com

bugs.python.org

bugzilla.redhat.com