Skip to main content
← All vulnerabilities
CVE-2014-3994GHSA-W7RQ-8F2G-JVQRPYSEC-2014-78

Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as u

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.7.30, 0.8.3
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • djbletsPyPI

    fixed in 0.7.30

  • djbletsPyPI

    From 0.8 · fixed in 0.8.3

  • djbletsPyPI

    fixed in 0.7.30; From 0.8 · fixed in 0.8.3

References 8

seclists.org

securityfocus.com

code.google.com

GitHub · djblets/djblets

secunia.com