CVE-2014-3589GHSA-CFMR-38G9-F2H7PYSEC-2014-10
PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a den
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.2, 2.5.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- pillowPyPI
fixed in 2.3.2
- pillowPyPI
From 2.5 · fixed in 2.5.2
- pillowPyPI
fixed in 2.3.2; From 2.5 · fixed in 2.5.2