Skip to main content
← All vulnerabilities
CVE-2014-3547GHSA-HWJV-MC78-CCCJ

Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x befor

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.7, 2.6.4, 2.7.1
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via an external badge.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.7

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.4

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.1

References 4

openwall.com

moodle.org

git.moodle.org

securityfocus.com