Skip to main content
← All vulnerabilities
CVE-2014-3546GHSA-4C5G-W3GF-RF4F

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 does not enforce certain capabili

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.11, 2.5.7, 2.6.4, 2.7.1
None on Exploit-DB, Metasploit or GitHub

Summary

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 does not enforce certain capability requirements in (1) notes/index.php and (2) user/edit.php, which allows remote attackers to obtain potentially sensitive username and course information via a modified URL.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.4.11

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.7

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.4

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.1

References 3

moodle.org

openwall.com

git.moodle.org