Skip to main content
← All vulnerabilities
CVE-2014-3541GHSA-FCCF-P8FX-VJJ4

The Repositories component in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 all

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.11, 2.5.7, 2.6.4, 2.7.1
None on Exploit-DB, Metasploit or GitHub

Summary

The Repositories component in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via serialized data associated with an add-on.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.4.11

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.7

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.4

  • moodle/moodlePackagist

    From 2.7.0 · fixed in 2.7.1

References 3

moodle.org

openwall.com

git.moodle.org